archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgnomekbd / trunk / PKGBUILD
blob8100347ef62776a4a5dbda11c46744dee783bbcb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libgnomekbd
5 pkgver=3.26.1+r5+g54da436
6 pkgrel=1
7 epoch=1
8 pkgdesc="Keyboard management library"
9 url="https://gitlab.gnome.org/GNOME/libgnomekbd"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(libxklavier gtk3 dconf)
13 makedepends=(gobject-introspection git)
14 provides=(libgnomekbd{,ui}.so)
15 options=(debug)
16 _commit=54da436258d79b683f57dfadf787bdf56ca58576  # master
17 source=("git+https://gitlab.gnome.org/GNOME/libgnomekbd.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
27   NOCONFIGURE=1 ./autogen.sh
30 build() {
31   cd "$pkgname"
32   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
33       --disable-schemas-compile --disable-static
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 package() {
39   cd "$pkgname"
40   make DESTDIR="$pkgdir" install
43 # vim:set sw=2 et: