archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libidn2 / repos / core-x86_64 / PKGBUILD
blobd845489e2f268dad286eeb84f46b661c598e9ea9
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Daurnimator <quae@daurnimator.com>
4 pkgname=libidn2
5 pkgver=2.3.3
6 pkgrel=1
7 pkgdesc="Free software implementation of IDNA2008, Punycode and TR46"
8 arch=('x86_64')
9 url="https://www.gnu.org/software/libidn/#libidn2"
10 license=('GPL2' 'LGPL3')
11 depends=('libunistring')
12 makedepends=('ruby-ronn')
13 provides=('libidn2.so')
14 source=(https://ftp.gnu.org/gnu/libidn/$pkgname-$pkgver.tar.gz{,.sig})
15 sha256sums=('f3ac987522c00d33d44b323cae424e2cffcb4c63c6aa6cd1376edacbf1c36eb0'
16             'SKIP')
17 validpgpkeys=('B1D2BD1375BECB784CF4F8C4D73CF638C53C06BE') # Simon Josefsson <simon@josefsson.org>
19 prepare() {
20   cd $pkgname-$pkgver
23 build() {
24   cd $pkgname-$pkgver
26   ./configure \
27     --prefix=/usr \
28     --disable-static
29   make
32 check() {
33   cd $pkgname-$pkgver
34   make check
36 package() {
37   cd $pkgname-$pkgver
38   make DESTDIR="$pkgdir" install
41 # vim:set ts=2 sw=2 et: