archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libsidplayfp / repos / extra-x86_64 / PKGBUILD
blobeb6438cef5ab3742ea7d918693c6dda4f1648a75
1 # Maintainer:
2 # Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
3 # Contributor: Gaetan Bisson <bisson@archlinux.org>
4 # Contributor: Simon Perry <aur [at] sanxion [dot] net>
5 # Contributor: Jonas Nyrén <jonas.nyren*mindkiller.com>
7 pkgname=libsidplayfp
8 pkgver=2.3.1
9 pkgrel=1
10 pkgdesc='Library to play Commodore 64 music, derived from libsidplay2'
11 url='https://github.com/libsidplayfp/libsidplayfp'
12 arch=(x86_64)
13 license=(GPL)
14 makedepends=(vice xa)
15 optdepends=('vice: better SID support')
16 source=("https://downloads.sourceforge.net/project/sidplay-residfp/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.gz")
17 sha256sums=('aef70cc30648eb89d32f56c691a5a40cdffc7421f43b4aa242f4d123eb9258a2')
19 build() {
20   cd $pkgname-$pkgver
21   ./configure --prefix=/usr
22   make
25 package() {
26   DESTDIR="$pkgdir" make -C $pkgname-$pkgver install
27   install -d "$pkgdir/usr/share/sidplayfp"
28   ln -t "$pkgdir/usr/share/sidplayfp" -s /usr/share/vice/C64/{kernal,basic,chargen}