archrelease: copy trunk to extra-x86_64
[arch-packages.git] / mm-common / repos / extra-any / PKGBUILD
blob5622fc211c7af17c2bf7689a9ce47a7eac35d7ae
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=mm-common
5 pkgver=1.0.4
6 pkgrel=1
7 pkgdesc="Common build files of the C++ bindings"
8 url="https://www.gtkmm.org/"
9 arch=(any)
10 depends=(graphviz doxygen gtk-doc libsigc++-docs perl-xml-parser)
11 makedepends=(libsigc++ git meson)
12 license=(GPL2)
13 _commit=1e163f565e907d71cbec98728aaa74ce2241adaf  # tags/1.0.4^0
14 source=("git+https://gitlab.gnome.org/GNOME/mm-common.git#commit=$_commit"
15         https://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/libstdc++.tag)
16 sha256sums=('SKIP'
17             'ea9631f749d33e927e950e1cc7db98f7270990d131e6f405562f793ad4c72fa9')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
26   cp ../libstdc++.tag doctags
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 et: