1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
7 pkgdesc="Common build files of the C++ bindings"
8 url="https://www.gtkmm.org/"
10 depends=(graphviz doxygen gtk-doc libsigc++-docs perl-xml-parser)
11 makedepends=(libsigc++ git meson)
13 _commit=1e163f565e907d71cbec98728aaa74ce2241adaf # tags/1.0.4^0
14 source=("git+https://gitlab.gnome.org/GNOME/mm-common.git#commit=$_commit"
15 https://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/libstdc++.tag)
17 'ea9631f749d33e927e950e1cc7db98f7270990d131e6f405562f793ad4c72fa9')
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 cp ../libstdc++.tag doctags
30 arch-meson $pkgname build
31 meson compile -C build
35 meson test -C build --print-errorlogs
39 meson install -C build --destdir "$pkgdir"