archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-digest-sha1 / trunk / PKGBUILD
blobebe983133a076b0dfb503462cd6cf2e849cda75a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: kevin <kevin@archlinux.org>
3 # Contributor: Manolis Tzanidakis
5 pkgname=perl-digest-sha1
6 pkgver=2.13
7 pkgrel=17
8 pkgdesc="Perl interface to the SHA-1 Algorithm"
9 arch=(x86_64)
10 license=('PerlArtistic')
11 url="https://search.cpan.org/dist/Digest-SHA1/"
12 depends=('perl')
13 options=('!emptydirs')
14 source=("https://www.cpan.org/authors/id/G/GA/GAAS/Digest-SHA1-$pkgver.tar.gz")
15 md5sums=('bd22388f268434f2b24f64e28bf1aa35')
17 build() {
18   cd Digest-SHA1-$pkgver
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd Digest-SHA1-$pkgver
25   make test
28 package() {
29   cd Digest-SHA1-$pkgver
30   make install DESTDIR="$pkgdir"
32 # vim: ts=2 sw=2 et ft=sh