1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Tobias Roettger <toroettg@gmail.com>
4 pkgname=python-platformdirs
7 pkgdesc='A small Python module for determining appropriate platform-specific dirs, e.g. a "user data dir"'
9 url="https://github.com/platformdirs/platformdirs"
11 depends=('python-typing_extensions')
12 makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-hatch-vcs')
13 checkdepends=('python-pytest-mock')
14 source=("https://pypi.io/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz")
15 sha512sums=('b0b0dee3ac4176e64f302b3d34e253b2e33784160051b9dafb563962e597df75f2c9f714c050d5bdeb1769a1f56c2878a47e9a42361596e287ae7b2afe870370')
18 cd "$srcdir"/platformdirs-$pkgver
19 python -m build --wheel --no-isolation
23 cd "$srcdir"/platformdirs-$pkgver
24 PYTHONPATH="$PWD"/src pytest
28 cd platformdirs-$pkgver
29 python -m installer --destdir="$pkgdir/" dist/*.whl
30 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/
33 # vim:set ts=2 sw=2 et: