archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python2 / repos / extra-x86_64 / PKGBUILD
bloba0d13709c99109c81460e441afdc709b8c31d10e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Jason Chu <jason@archlinux.org>
6 pkgname=python2
7 pkgver=2.7.18
8 pkgrel=5
9 _pybasever=2.7
10 pkgdesc="A high-level scripting language"
11 arch=('x86_64')
12 license=('PSF')
13 url="https://www.python.org/"
14 depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'sqlite' 'zlib')
15 makedepends=('tk' 'bluez-libs')
16 checkdepends=('gdb' 'file' 'xorg-server-xvfb')
17 optdepends=('tk: for IDLE'
18             'python2-setuptools'
19             'python2-pip')
20 conflicts=('python<3')
21 _gentoo_patches="python-gentoo-patches-${pkgver}_p7"
22 source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
23         mtime-workaround.patch
24         "https://dev.gentoo.org/~mgorny/dist/python/$_gentoo_patches.tar.xz"
25         py2-ize-the-CJK-codec-test.patch)
26 sha512sums=('a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c'
27             'SKIP'
28             '4e761cfd57791e8b72ecdf84c2e03875bf074311130eea5b8e97409fa304fa3468dbd359a511c4e9978e686e662c58054b4174d3e73f845fa9ded2e83a3a8076'
29             'a3cd34f38a717183d9a8d6b91817a6ac989fb8ae4275f35cba4be810813a4c9c45f4e72d16aee33904eddaee77c4719b516392d629d2c4627c840e4ecc6bc121'
30             '67fb8116825f646cbe0f12d9ffb68c2e2006e98721c80c674738315160c0dfdb5f200b8d3229f85dbac2510ba436b0f701e44542ce4494cdd191cd1b8ca0bf0f')
31 validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF')  # Benjamin Peterson
32 noextract=("$_gentoo_patches.tar.xz")
34 prepare() {
35   bsdtar -xf $_gentoo_patches.tar.xz -s /$_gentoo_patches//
37   cd Python-${pkgver}
39   # makepkg will touch all files to $SOURCE_DATE_EPOCH which will break pyc file's mtime check.
40   # workaround this by touching them to $SOURCE_DATE_EPOCH before running compileall.
41   patch -p0 -i ../mtime-workaround.patch
43   patch -p1 -i ../0001-bpo-39017-Avoid-infinite-loop-in-the-tarfile-module-.patch #CVE-2019-20907
44   patch -p1 -i ../0002-bpo-39503-CVE-2020-8492-Fix-AbstractBasicAuthHandler.patch #CVE-2020-8492
45   patch -p1 -i ../0003-bpo-39603-Prevent-header-injection-in-http-methods-G.patch #CVE-2020-26116
46   patch -p1 -i ../0004-bpo-42051-Reject-XML-entity-declarations-in-plist-fi.patch
47   patch -p1 -i ../0005-bpo-41944-No-longer-call-eval-on-content-received-vi.patch #CVE-2020-27619
48   patch -p1 -i ../0006-bpo-40791-Make-compare_digest-more-constant-time.-GH.patch
49   patch -p1 -i ../0007-3.6-closes-bpo-42938-Replace-snprintf-with-Python-un.patch #CVE-2021-3177
50   patch -p1 -i ../0024-3.6-bpo-42967-only-use-as-a-query-string-separator-G.patch #CVE-2021-23336
51   patch -p1 -i ../py2-ize-the-CJK-codec-test.patch
53   # Temporary workaround for FS#22322
54   # See http://bugs.python.org/issue10835 for upstream report
55   sed -i "/progname =/s/python/python${_pybasever}/" Python/pythonrun.c
57   # Enable built-in SQLite module to load extensions (fix FS#22122)
58   sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
60   # FS#23997
61   sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python2|" Lib/cgi.py
63   sed -i "s/python2.3/python2/g" Lib/distutils/tests/test_build_scripts.py \
64     Lib/distutils/tests/test_install_scripts.py
66   # Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
67   # rather than copies shipped in the tarball
68   rm -r Modules/expat
69   rm -r Modules/zlib
70   rm -r Modules/_ctypes/{darwin,libffi}*
72   # clean up #!s
73   find . -name '*.py' | \
74     xargs sed -i "s|#[ ]*![ ]*/usr/bin/env python$|#!/usr/bin/env python2|"
76   # Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
77   touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
80 build() {
81   cd "${srcdir}/Python-${pkgver}"
83   export OPT="${CFLAGS}"
84   ./configure --prefix=/usr \
85               --enable-shared \
86               --with-threads \
87               --enable-optimizations \
88               --with-lto \
89               --enable-ipv6 \
90               --enable-unicode=ucs4 \
91               --with-system-expat \
92               --with-system-ffi \
93               --with-dbmliborder=gdbm:ndbm \
94               --without-ensurepip
96   make
99 check() {
100   # Since 2.7.14 with latest xvfb
101   # test_idle, test_tk, test_ttk_guionly: segfaults
102   # Since 2.7.15: test_ctypes
103   # test_ftplib test_imaplib test_urllib2_localnet: krb5 errors
104   # test_codecmaps_jp: TODO
106   cd Python-${pkgver}
107   LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
108     xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_idle test_tk test_ttk_guionly test_ctypes test_ssl test_ftplib test_imaplib test_urllib2_localnet test_codecmaps_jp
111 package() {
112   cd Python-${pkgver}
114   # Hack to avoid building again
115   sed -i 's/^all:.*$/all: build_all/' Makefile
117   make DESTDIR="${pkgdir}" altinstall maninstall
119   rm "${pkgdir}"/usr/share/man/man1/python.1
121   ln -sf python${_pybasever}        "${pkgdir}"/usr/bin/python2
122   ln -sf python${_pybasever}-config "${pkgdir}"/usr/bin/python2-config
123   ln -sf python${_pybasever}.1      "${pkgdir}"/usr/share/man/man1/python2.1
125   # FS#33954
126   ln -sf python-${_pybasever}.pc    "${pkgdir}"/usr/lib/pkgconfig/python2.pc
128   ln -sf ../../libpython${_pybasever}.so "${pkgdir}"/usr/lib/python${_pybasever}/config/libpython${_pybasever}.so
130   mv "${pkgdir}"/usr/bin/smtpd.py "${pkgdir}"/usr/lib/python${_pybasever}/
132   # some useful "stuff"
133   install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
134   install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
135   install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
137   # fix conflicts with python
138   mv "${pkgdir}"/usr/bin/idle{,2}
139   mv "${pkgdir}"/usr/bin/pydoc{,2}
140   mv "${pkgdir}"/usr/bin/2to3{,-2.7}
142   # clean-up reference to build directory
143   sed -i "s#${srcdir}/Python-${pkgver}:##" "${pkgdir}"/usr/lib/python${_pybasever}/config/Makefile
145   # license
146   install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE