archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-svg / repos / extra-x86_64 / PKGBUILD
blob80e9333e81c6eac407f5f316671dae192038e70f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt5-svg
6 _basever=5.15.5
7 pkgver=5.15.5+kde+r11
8 pkgrel=1
9 _commit=b8e1a7eb5e45880dc97b9b29d2844bc9c07708a7
10 arch=('x86_64')
11 url='https://www.qt.io'
12 license=('GPL3' 'LGPL3' 'FDL' 'custom')
13 pkgdesc='Classes for displaying the contents of SVG files'
14 depends=('qt5-base')
15 makedepends=('git')
16 groups=('qt' 'qt5')
17 _pkgfqn=${pkgname/5-/}
18 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
19 sha256sums=('SKIP')
20 options=(debug)
22 pkgver() {
23   cd $_pkgfqn
24   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
27 prepare() {
28   mkdir -p build
31 build() {
32   cd build
34   qmake ../${_pkgfqn}
35   make
38 package() {
39   cd build
40   make INSTALL_ROOT="$pkgdir" install
42   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
43   find "$pkgdir/usr/lib" -type f -name '*.prl' \
44     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
46   install -d "$pkgdir"/usr/share/licenses
47   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}