1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
11 url='https://github.com/qtwebkit/qtwebkit'
12 license=(GPL3 LGPL3 FDL custom)
13 pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
14 source=("https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz"
17 qt5-webkit-python-3.9.patch::"https://github.com/qtwebkit/qtwebkit/commit/78360c01.patch"
18 qt5-webkit-bison-3.7.patch::"https://github.com/qtwebkit/qtwebkit/commit/d92b11fe.patch")
19 depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2)
20 makedepends=(cmake ruby gperf python qt5-doc qt5-tools)
21 optdepends=('gst-plugins-good: Webm codec support')
22 sha256sums=('9ca126da9273664dd23a3ccd0c9bebceb7bb534bddd743db31caf6a5a6d4a9e6'
23 '0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0'
24 '4969dd03e482155e2490b50307dada81dda7bbc9e5398e3a53c20bc474f7c04e'
25 '6e0cee08e4fa57b04752e80817f33562f48aa42608a3a620930b6040259b4932'
26 '34f37b53ee0bc31c63ce85ebd1ae95543a8ba28483e387b20efd50574bd813be')
31 patch -p0 -i ../icu68.patch # Fix build with ICU 68.x
32 patch -p1 -i ../glib-2.68.patch # https://github.com/qtwebkit/qtwebkit/issues/1057
33 patch -p1 -i ../qt5-webkit-python-3.9.patch # Fix build with python 3.9
34 patch -p1 -i ../qt5-webkit-bison-3.7.patch # Fix build with bison 3.7
38 cmake -B build -S qtwebkit-$_pkgver \
39 -DCMAKE_INSTALL_PREFIX=/usr \
40 -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG" \
47 DESTDIR="$pkgdir" cmake --install build
49 install -d "$pkgdir"/usr/share/licenses
50 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}