archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-pulseaudio-plugin / trunk / PKGBUILD
blob2529e1b2e84128364bddb12730d7a8d8bf6897e0
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
4 # Contributor: <alcasa dot mz at gmail dot com>
5 # Contributor: twa022 <twa022 at gmail dot com>
7 pkgname=xfce4-pulseaudio-plugin
8 pkgver=0.4.3
9 pkgrel=2
10 pkgdesc="Pulseaudio plugin for the Xfce4 panel"
11 arch=('x86_64')
12 url="https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin"
13 license=('GPL2')
14 groups=('xfce4-goodies')
15 depends=('xfce4-panel' 'libpulse' 'libkeybinder3' 'libnotify')
16 makedepends=('intltool')
17 optdepends=('pavucontrol: default pulseaudio mixer')
18 source=("git+https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/#commit=$_commit")
19 source=(https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
20 sha256sums=('5a518237e2137341d8ca6584938950525e20c28a0177e30ecaea3ba8e7a2615b')
22 build() {
23   cd $pkgname-$pkgver
25   ./configure \
26     --prefix=/usr \
27     --sysconfdir=/etc \
28     --libexecdir=/usr/lib \
29     --localstatedir=/var
30   make
33 package() {
34   cd $pkgname-$pkgver
35   make DESTDIR="$pkgdir" install