102.11.0-1
[arch-packages.git] / amf-headers / trunk / PKGBUILD
blobf4aedcb168258bfe3c228985b57fbda22d68c90f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Daniel Bermond <dbermond@archlinux.org>
4 pkgname=amf-headers
5 pkgver=1.4.29
6 pkgrel=1
7 pkgdesc='Header files for AMD Advanced Media Framework'
8 arch=(any)
9 url=https://github.com/GPUOpen-LibrariesAndSDKs/AMF/
10 license=(MIT)
11 makedepends=(git)
12 _tag=bc64bf6e8bfca3083755b7cbec3c23d5546fb04a
13 source=(git+https://github.com/GPUOpen-LibrariesAndSDKs/AMF.git#tag=${_tag})
14 b2sums=(SKIP)
16 pkgver() {
17   cd AMF
19   git describe --tags | sed 's/^v//'
22 package() {
23   install -dm 755 "${pkgdir}"/usr/include
24   cp -dr --no-preserve=ownership AMF/amf/public/include "${pkgdir}"/usr/include/AMF
25   install -Dm 644 AMF/LICENSE.txt -t "${pkgdir}"/usr/share/licenses/amf-headers/
28 # vim: ts=2 sw=2 et: