102.11.0-1
[arch-packages.git] / baobab / repos / extra-x86_64 / PKGBUILD
blob4cb3bde18f681476626cd8d40ebd9d27f08d4ba0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=baobab
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="A graphical directory tree analyzer"
8 url="https://wiki.gnome.org/Apps/DiskUsageAnalyzer"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(
12   dconf
13   gsettings-desktop-schemas
14   gtk4
15   libadwaita
16   librsvg
18 makedepends=(
19   appstream-glib
20   git
21   gobject-introspection
22   meson
23   vala
24   yelp-tools
26 groups=(gnome)
27 _commit=13681aee6a35c8d4f98fa7a92736ffb6dc757e0f  # tags/44.0^0
28 source=(
29   "git+https://gitlab.gnome.org/GNOME/baobab.git#commit=$_commit"
30   no-mimetype.diff
32 b2sums=('SKIP'
33         '71e04f307e842fa0676f5b64f55e8be908e3075a9b948a6ab3979b51a8db08fdd07c0f214adb74d5461b4f175a14a7bf9867cf2c9b044660a5b46bc8ea296a22')
35 pkgver() {
36   cd baobab
37   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
40 prepare() {
41   cd baobab
43   # https://bugs.archlinux.org/task/31861
44   git apply -3 ../no-mimetype.diff
47 build() {
48   arch-meson baobab build
49   meson compile -C build
52 check() {
53   meson test -C build --print-errorlogs
56 package() {
57   meson install -C build --destdir "$pkgdir"
60 # vim:set sw=2 sts=-1 et: