102.11.0-1
[arch-packages.git] / cheese / repos / extra-x86_64 / PKGBUILD
blob1631968c6ffcaef222a4b6060f79125c9e5d51c1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=cheese
5 pkgname=(
6   cheese
7   libcheese
9 pkgver=44.0.1
10 pkgrel=1
11 pkgdesc="Take photos and videos with your webcam, with fun graphical effects"
12 url="https://wiki.gnome.org/Apps/Cheese"
13 arch=(x86_64)
14 license=(GPL)
15 depends=(
16   clutter-gst
17   clutter-gtk
18   dconf
19   gnome-desktop
20   gnome-video-effects
21   gst-plugins-bad
22   gst-plugins-base
23   gst-plugins-good
24   gstreamer
25   gtk3
26   libcanberra
27   libgudev
28   librsvg
30 makedepends=(
31   appstream-glib
32   git
33   gobject-introspection
34   meson
35   vala
36   yelp-tools
38 checkdepends=(xorg-server-xvfb)
39 _commit=7dbce9f06de65233ab0bf20e59a85d04850b94a8  # tags/44.0.1^0
40 source=("git+https://gitlab.gnome.org/GNOME/cheese.git#commit=$_commit")
41 b2sums=('SKIP')
43 pkgver() {
44   cd cheese
45   git describe --tags | sed 's/\.\([a-z]\)/\1/;s/[^-]*-g/r&/;s/-/+/g'
48 prepare() {
49   cd cheese
52 build() {
53   arch-meson cheese build -D tests=true
54   meson compile -C build
57 check() (
58   export GSETTINGS_SCHEMA_DIR="$PWD/cheese/data"
59   glib-compile-schemas "$GSETTINGS_SCHEMA_DIR"
61   dbus-run-session xvfb-run -s '-nolisten local' \
62     meson test -C build --print-errorlogs
65 _pick() {
66   local p="$1" f d; shift
67   for f; do
68     d="$srcdir/$p/${f#$pkgdir/}"
69     mkdir -p "$(dirname "$d")"
70     mv "$f" "$d"
71     rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
72   done
75 package_cheese() {
76   depends+=("libcheese=$pkgver-$pkgrel")
77   groups=(gnome)
79   meson install -C build --destdir "$pkgdir"
81   cd "$pkgdir"
83   _pick libs usr/include
84   _pick libs usr/lib/{girepository-1.0,libcheese*,pkgconfig}
85   _pick libs usr/share/{gir-1.0,glib-2.0/schemas,gtk-doc}
88 package_libcheese() {
89   pkgdesc="Webcam widget for Clutter and GTK"
90   depends=(
91     clutter
92     clutter-gst
93     clutter-gtk
94     gdk-pixbuf2
95     glib2
96     gst-plugins-bad-libs
97     gst-plugins-base-libs
98     gstreamer
99     gtk3
100     libcanberra
101   )
102   provides=(libcheese{,-gtk}.so)
104   mv libs/* "$pkgdir"
107 # vim:set sw=2 sts=-1 et: