102.11.0-1
[arch-packages.git] / gdk-pixbuf-xlib / repos / extra-x86_64 / PKGBUILD
blobb37153ada52a4808b0ad941f9eba433a560e0df2
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gdk-pixbuf-xlib
4 pkgver=2.40.2
5 pkgrel=2
6 pkgdesc="Deprecated Xlib integration for GdkPixbuf"
7 arch=(x86_64)
8 url="https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib"
9 license=(LGPL2.1)
10 depends=(gdk-pixbuf2 libx11)
11 makedepends=(gtk-doc git meson)
12 options=(debug)
13 _commit=c142b818801e0affceea4a2139cf5630a283e54e  # tags/2.40.2^0
14 source=("git+$url.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -D gtk_doc=true
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   depends+=(libgdk_pixbuf-2.0.so)
37   provides+=(libgdk_pixbuf_xlib-2.0.so)
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: