102.11.0-1
[arch-packages.git] / geoclue2 / trunk / PKGBUILD
blobd064561ffbcaf809daaaad6a99322ae5273f7229
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: György Balló <ballogy@freestart.hu>
4 pkgname=geoclue2
5 pkgver=2.5.2
6 pkgrel=2
7 pkgdesc="Modular geoinformation service built on the D-Bus messaging system"
8 arch=(x86_64)
9 url="https://www.freedesktop.org/wiki/Software/GeoClue/"
10 license=(LGPL)
11 depends=(libsoup json-glib libmm-glib avahi geocode-glib)
12 makedepends=(systemd gobject-introspection git vala meson gtk-doc libnotify)
13 optdepends=('libnotify: Demo Agent')
14 backup=(etc/geoclue/geoclue.conf)
15 conflicts=(geoclue)
16 _commit=ed2d81fe558b657b52940dd52316bcc1a32d0cff  # tags/2.5.2^0
17 source=("git+https://gitlab.freedesktop.org/geoclue/geoclue.git#commit=$_commit")
18 sha256sums=('SKIP')
20 # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
21 # Note: These are for Arch Linux use ONLY. For your own distribution, please
22 # get your own set of keys. Feel free to contact foutrelis@archlinux.org for
23 # more information.
24 _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
26 # Mozilla API keys (see https://location.services.mozilla.com/api)
27 # Note: These are for Arch Linux use ONLY. For your own distribution, please
28 # get your own set of keys. Feel free to contact heftig@archlinux.org for
29 # more information.
30 _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
32 pkgver() {
33   cd geoclue
34   git describe --tags | sed 's/-/+/g'
37 prepare() {
38   cd geoclue
39   sed -e "s/key=geoclue/key=$_mozilla_api_key/" \
40       -e "s/key=YOUR_KEY/key=$_google_api_key/" \
41       -i data/geoclue.conf.in
44 build() {
45   arch-meson geoclue build -D dbus-sys-dir=/usr/share/dbus-1/system.d
46   ninja -C build
49 check() {
50   meson test -C build
53 package() {
54   DESTDIR="$pkgdir" meson install -C build
57 # vim:set sw=2 et: