1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Automatic archives creating and extracting library"
8 url="https://wiki.gnome.org/TingweiLan/GSoC2013Final"
23 provides=(libgnome-autoar{,-gtk}-${pkgver%%.*}.so)
24 _commit=b387c2482d2a5c8efdfc8c7498f13cd3881685c0 # tags/0.4.4^0
25 source=("git+https://gitlab.gnome.org/GNOME/gnome-autoar.git#commit=$_commit")
30 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
44 arch-meson $pkgname build "${meson_options[@]}"
45 meson compile -C build
49 meson test -C build --print-errorlogs
53 meson install -C build --destdir "$pkgdir"
56 # vim:set sw=2 sts=-1 et: