102.11.0-1
[arch-packages.git] / gnome-autoar / trunk / PKGBUILD
blob7e19b86be52b418cfad2bc1ab910ef22a5531ab5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-autoar
5 pkgver=0.4.4
6 pkgrel=1
7 pkgdesc="Automatic archives creating and extracting library"
8 url="https://wiki.gnome.org/TingweiLan/GSoC2013Final"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   glib2
13   gtk3
14   libarchive
16 makedepends=(
17   git
18   gobject-introspection
19   gtk-doc
20   meson
21   vala
23 provides=(libgnome-autoar{,-gtk}-${pkgver%%.*}.so)
24 _commit=b387c2482d2a5c8efdfc8c7498f13cd3881685c0  # tags/0.4.4^0
25 source=("git+https://gitlab.gnome.org/GNOME/gnome-autoar.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
37 build() {
38   local meson_options=(
39     -D gtk_doc=true
40     -D tests=true
41     -D vapi=true
42   )
44   arch-meson $pkgname build "${meson_options[@]}"
45   meson compile -C build
48 check() {
49   meson test -C build --print-errorlogs
52 package() {
53   meson install -C build --destdir "$pkgdir"
56 # vim:set sw=2 sts=-1 et: