102.11.0-1
[arch-packages.git] / openal / trunk / PKGBUILD
blob0b1646e25bcc4937155c782e9fd9c946920b804a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Jason Chu <jchu@xentac.net>
5 pkgbase=openal
6 pkgname=(
7   openal
8   openal-examples
10 pkgver=1.23.1
11 pkgrel=1
12 pkgdesc="Cross-platform 3D audio library, software implementation"
13 url="https://github.com/kcat/openal-soft"
14 arch=(x86_64)
15 license=(LGPL)
16 depends=(
17   gcc-libs
19 makedepends=(
20   alsa-lib
21   cmake
22   ffmpeg
23   fluidsynth
24   git
25   jack
26   libmysofa
27   libpulse
28   libsndfile
29   ninja
30   pipewire
31   portaudio
32   qt5-base
33   sdl2
35 optdepends=(
36   'qt5-base: alsoft-config GUI Configurator'
37   'fluidsynth: MIDI rendering'
38   'libmysofa: makemhr tool'
40 _commit=d3875f333fb6abe2f39d82caca329414871ae53b  # tags/1.23.1
41 source=("git+https://github.com/kcat/openal-soft#commit=$_commit")
42 b2sums=('SKIP')
44 pkgver() {
45   cd openal-soft
46   git describe --tags | sed 's/^openal-soft-//;s/[^-]*-g/r&/;s/-/+/g'
49 prepare() {
50   cd openal-soft
53 build() {
54   local cmake_options=(
55     -DCMAKE_INSTALL_PREFIX=/usr
56     -DCMAKE_BUILD_TYPE=None
57     -DCMAKE_INSTALL_LIBDIR=lib
58   )
60   cmake -S openal-soft -B build -G Ninja "${cmake_options[@]}"
61   cmake --build build
64 _pick() {
65   local p="$1" f d; shift
66   for f; do
67     d="$srcdir/$p/${f#$pkgdir/}"
68     mkdir -p "$(dirname "$d")"
69     mv "$f" "$d"
70     rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
71   done
74 package_openal() {
75   provides+=(libopenal.so)
77   DESTDIR="$pkgdir" cmake --install build
78   install -Dt "$pkgdir/usr/share/doc/openal" -m644 openal-soft/docs/*
80   cd "$pkgdir"
81   _pick examples usr/bin/al{ffplay,hrtf,latency,loopback,multireverb}
82   _pick examples usr/bin/al{play,record,reverb,stream,tonegen}
85 package_openal-examples() {
86   pkgdesc+=" (example programs)"
87   depends=("openal=$pkgver-$pkgrel" sdl2 libsndfile ffmpeg)
88   optdepends=()
89   mv examples/* "$pkgdir"
92 # vim:set sw=2 sts=-1 et: