102.11.0-1
[arch-packages.git] / perl-test-pod / trunk / PKGBUILD
blob584f4eec5cde2463a375ca7d08db124e612a6623
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Kevin <kevin@archlinux.org>
3 # Contributor: Firmicus <francois.archlinux.org> 
5 pkgname=perl-test-pod
6 pkgver=1.52
7 pkgrel=7
8 pkgdesc="Check for POD errors in files"
9 arch=('any')
10 url="https://search.cpan.org/dist/Test-Pod/"
11 license=('GPL' 'PerlArtistic')
12 depends=('perl')
13 options=('!emptydirs')
14 source=(https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Pod-${pkgver}.tar.gz)
15 sha512sums=('9b078488e1da8b907f5f3a46452aa9bfd49db61f1539d076dccebf9a8b476eaf0f539f00badc9c500b1e732a8827331b2286375924986efb990367767eeb8365')
17 build() {
18   cd Test-Pod-${pkgver}
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd Test-Pod-${pkgver}
25   make test
28 package() {
29   cd Test-Pod-${pkgver}
30   make DESTDIR="${pkgdir}" install