102.11.0-1
[arch-packages.git] / python-cairo / trunk / PKGBUILD
blob03da096930ca3c79c13bc863bef776a58a4222df
1 # Contributor: Angel Velasquez <angvp@archlinux.org>  
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=python-cairo
5 pkgver=1.23.0
6 pkgrel=4
7 pkgdesc="Python bindings for the cairo graphics library"
8 url="https://pycairo.readthedocs.io/en/latest/"
9 arch=(x86_64)
10 license=(LGPL2.1 MPL)
11 depends=(cairo python)
12 makedepends=(meson)
13 checkdepends=(python-pytest)
14 source=(https://github.com/pygobject/pycairo/releases/download/v$pkgver/pycairo-$pkgver.tar.gz{,.sig})
15 sha256sums=('9b61ac818723adc04367301317eb2e814a83522f07bbd1f409af0dada463c44c'
16             'SKIP')
17 validpgpkeys=(0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC) # Christoph Reiter <reiter.christoph@gmail.com>
19 prepare() {
20   cd pycairo-$pkgver
23 build() {
24   arch-meson pycairo-$pkgver build
25   meson compile -C build
28 check() {
29   meson test -C build --print-errorlogs
32 package() {
33   meson install -C build --destdir="$pkgdir"
35   # compile Python bytecode
36   python -m compileall -d /usr/lib "$pkgdir/usr/lib"
37   python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
40 # vim:set sw=2 sts=-1 et: