1 # Contributor: Angel Velasquez <angvp@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Python bindings for the cairo graphics library"
8 url="https://pycairo.readthedocs.io/en/latest/"
11 depends=(cairo python)
13 checkdepends=(python-pytest)
14 source=(https://github.com/pygobject/pycairo/releases/download/v$pkgver/pycairo-$pkgver.tar.gz{,.sig})
15 sha256sums=('9b61ac818723adc04367301317eb2e814a83522f07bbd1f409af0dada463c44c'
17 validpgpkeys=(0EBF782C5D53F7E5FB02A66746BD761F7A49B0EC) # Christoph Reiter <reiter.christoph@gmail.com>
24 arch-meson pycairo-$pkgver build
25 meson compile -C build
29 meson test -C build --print-errorlogs
33 meson install -C build --destdir="$pkgdir"
35 # compile Python bytecode
36 python -m compileall -d /usr/lib "$pkgdir/usr/lib"
37 python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
40 # vim:set sw=2 sts=-1 et: