102.11.0-1
[arch-packages.git] / python-packaging / trunk / PKGBUILD
blobc8ad08a3c71896e6bc154238f62723df75a741f1
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-packaging
4 pkgver=23.1
5 pkgrel=1
6 pkgdesc="Core utilities for Python packages"
7 arch=('any')
8 url="https://github.com/pypa/packaging"
9 license=('Apache')
10 depends=('python')
11 makedepends=('python-build' 'python-installer' 'python-flit-core')
12 checkdepends=('python-pytest' 'python-pretend')
13 source=("https://github.com/pypa/packaging/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('1e717a2c97371e177f6b73de8de0440384e7abf361771e68b1696bc8e67d9d0995d2aeb2037995a16ecd374f58317793e66574c9fc28691b4e6094ece69cb5f0')
16 build() {
17   cd packaging-$pkgver
18   python -m build -nw
21 check() {
22   cd packaging-$pkgver
23   PYTHONPATH=src pytest
26 package() {
27   cd packaging-$pkgver
28   python -m installer --destdir="$pkgdir" dist/*.whl