102.11.0-1
[arch-packages.git] / switcheroo-control / repos / extra-x86_64 / PKGBUILD
blob8b4b9bca65c1c58349a7189dc9e2210b36cb9fd4
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
3 # Contributor: Mantas <grawity at gmail dot com>
5 pkgname=switcheroo-control
6 pkgver=2.6
7 pkgrel=4
8 pkgdesc="D-Bus service to check the availability of dual-GPU"
9 url="https://gitlab.freedesktop.org/hadess/switcheroo-control"
10 arch=(x86_64)
11 license=(GPL3)
12 depends=(
13   glib2
14   libgudev
15   python-gobject
17 makedepends=(
18   git
19   gtk-doc
20   meson
21   python-dbus
22   python-dbusmock
23   systemd
25 checkdepends=(umockdev)
26 _commit=0dd257edd6b27589d2a1013cda1d2d5f325eee8b  # tags/2.6^0
27 source=("git+$url.git#commit=$_commit")
28 b2sums=('SKIP')
30 pkgver() {
31   cd $pkgname
32   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
35 build() {
36   local meson_options=(
37     -D gtk_doc=true
38     -D tests=true
39   )
41   arch-meson $pkgname build "${meson_options[@]}"
42   meson compile -C build
45 check() {
46   meson test -C build --print-errorlogs
49 package() {
50   meson install -C build --destdir "$pkgdir"
53 # vim:set sw=2 sts=-1 et: