102.11.0-1
[arch-packages.git] / syndication / trunk / PKGBUILD
blob993b14430db61b754dea9fb236568727051ebca1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=syndication
4 pkgver=5.106.0
5 pkgrel=1
6 pkgdesc='RSS/Atom parser library'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 depends=(kcodecs)
11 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
12 groups=(kf5)
13 conflicts=(kde-syndication)
14 provides=(kde-syndication)
15 replaces=(kde-syndication)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('d00d3fcb700f73295f6a05aebc6e96b316548cd90241376ff8e1d913e3d5f79f'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build