102.11.0-1
[arch-packages.git] / tracker3 / trunk / PKGBUILD
blobbf0eb4cf3ab69ebafdc644655699cfe0e0296ab6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Alexander Fehr <pizzapunk gmail com>
5 pkgbase=tracker3
6 pkgname=(
7   tracker3
8   tracker3-docs
10 pkgver=3.5.2
11 pkgrel=1
12 pkgdesc="Desktop-neutral user information store, search tool and indexer"
13 url="https://wiki.gnome.org/Projects/Tracker"
14 arch=(x86_64)
15 license=(GPL)
16 depends=(
17   glib2
18   icu
19   json-glib
20   libsoup3
21   libstemmer
22   libxml2
23   sqlite
25 makedepends=(
26   asciidoc
27   bash-completion
28   dbus
29   gi-docgen
30   git
31   gobject-introspection
32   libsoup
33   meson
34   python-dbus
35   python-gobject
36   python-tappy
37   systemd
38   vala
40 _commit=11d90648022edb45fbabf43f0f64809ed53aeeab  # tags/3.5.2^0
41 source=(
42   "git+https://gitlab.gnome.org/GNOME/tracker.git#commit=$_commit"
43   "git+https://gitlab.gnome.org/GNOME/gvdb.git"
45 b2sums=('SKIP'
46         'SKIP')
48 pkgver() {
49   cd tracker
50   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
53 prepare() {
54   cd tracker
56   git submodule init
57   git submodule set-url subprojects/gvdb "$srcdir/gvdb"
58   git -c protocol.file.allow=always submodule update
61 build() {
62   local meson_options=(
63     -D tests_tap_protocol=true
64   )
66   arch-meson tracker build "${meson_options[@]}"
67   meson compile -C build
70 check() {
71   dbus-run-session meson test -C build --print-errorlogs -t 3
74 package_tracker3() {
75   optdepends=('libsoup: Alternative remoting backend')
76   provides=(libtracker-sparql-3.0.so)
78   meson install -C build --destdir "$pkgdir"
80   mkdir -p docs/usr/share
81   mv {"$pkgdir",docs}/usr/share/doc
84 package_tracker3-docs() {
85   pkgdesc+=" (documentation)"
86   depends=()
87   mv docs/* "$pkgdir"
90 # vim:set sw=2 sts=-1 et: