102.11.0-1
[arch-packages.git] / xfce4-panel / trunk / PKGBUILD
blob46151faea1d5bf4870ad259b41d4df54040950b6
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: tobias <tobias funnychar archlinux.org>
4 pkgname=xfce4-panel
5 pkgver=4.18.3
6 pkgrel=1
7 pkgdesc="Panel for the Xfce desktop environment"
8 arch=('x86_64')
9 url="https://docs.xfce.org/xfce/xfce4-panel/start"
10 license=('GPL2')
11 groups=('xfce4')
12 depends=('exo' 'garcon' 'libxfce4ui' 'xfconf' 'libwnck3' 'libdbusmenu-gtk3'
13          'hicolor-icon-theme' 'desktop-file-utils')
14 makedepends=('intltool' 'gobject-introspection' 'vala')
15 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
16 sha256sums=('4ae0b8615c9811194bbda0172a63567ed7fdb5519ea48f7a4637f4e6e5365e1b')
18 prepare() {
19   cd $pkgname-$pkgver
22 build() {
23   cd $pkgname-$pkgver
25   ./configure \
26     --prefix=/usr \
27     --sysconfdir=/etc \
28     --localstatedir=/var \
29     --enable-gio-unix \
30     --disable-debug
31   make
34 package() {
35   cd $pkgname-$pkgver
36   make DESTDIR="$pkgdir" install
39 # vim:set ts=2 sw=2 et: