102.11.0-1
[arch-packages.git] / zeitgeist / trunk / PKGBUILD
blob09a30b27518c0263d11cf5b5fe33e4f20309b295
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: György Balló <ballogy@freestart.hu>
5 pkgname=zeitgeist
6 pkgver=1.0.4
7 pkgrel=2
8 pkgdesc="Service logging user activities and events"
9 arch=(x86_64)
10 url="https://launchpad.net/zeitgeist/"
11 license=(GPL2 LGPL2.1)
12 depends=(json-glib telepathy-glib gtk3 xapian-core sqlite)
13 makedepends=(gobject-introspection vala raptor python-rdflib git)
14 provides=(zeitgeist-datahub)
15 conflicts=(zeitgeist-datahub)
16 replaces=(zeitgeist-datahub)
17 _commit=8b89364c077b46734d193c5b8a80f83b0fc917dd
18 source=("git+https://gitlab.freedesktop.org/zeitgeist/zeitgeist#commit=$_commit")
19 sha256sums=('SKIP')
20 validpgpkeys=('E4884AEEDE4CC02043C3D8045DECDBA89270E723') #Rico Tzschichholz <ricotz@ubuntu.com>
22 pkgver() {
23   cd $pkgname
24   git describe --tags | sed 's/^v//;s/-/+/g'
27 prepare() {
28   cd $pkgname
29   autoreconf -fi
32 build() {
33   cd $pkgname
34   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
35     --libexecdir=/usr/lib --enable-fts
36   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
37   make
40 check() {
41   cd $pkgname
42   # Log test fails in chroot, as we have no X and no proper dbus
43   make -k check || :
46 package() {
47   cd $pkgname
48   make DESTDIR="$pkgdir" install