1 # Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
2 # Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
7 pkgdesc="A C++ unit testing framework"
9 url="https://www.freedesktop.org/wiki/Software/cppunit"
11 depends=('sh' 'gcc-libs')
12 makedepends=('doxygen')
13 options=('!emptydirs')
14 source=(https://dev-www.libreoffice.org/src/${pkgname}-${pkgver}.tar.gz)
15 sha256sums=('89c5c6665337f56fd2db36bc3805a5619709d51fb136e51937072f63fcc717a7')
18 cd ${pkgname}-${pkgver}
19 ./configure --prefix=/usr --disable-static
20 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
25 cd ${pkgname}-${pkgver}
30 cd ${pkgname}-${pkgver}
31 make DESTDIR="${pkgdir}" install