archrelease: copy trunk to extra-x86_64
[arch-packages.git] / cppunit / trunk / PKGBUILD
blob6f51af62dc96834e0a0758cab55b78890de7d4cb
1 # Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
2 # Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
4 pkgname=cppunit
5 pkgver=1.15.1
6 pkgrel=3
7 pkgdesc="A C++ unit testing framework"
8 arch=('x86_64')
9 url="https://www.freedesktop.org/wiki/Software/cppunit"
10 license=('LGPL')
11 depends=('sh' 'gcc-libs')
12 makedepends=('doxygen')
13 options=('!emptydirs')
14 source=(https://dev-www.libreoffice.org/src/${pkgname}-${pkgver}.tar.gz)
15 sha256sums=('89c5c6665337f56fd2db36bc3805a5619709d51fb136e51937072f63fcc717a7')
17 build() {
18    cd ${pkgname}-${pkgver}
19    ./configure --prefix=/usr --disable-static
20    sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21    make
24 check() {
25   cd ${pkgname}-${pkgver}
26   make check
29 package() {
30    cd ${pkgname}-${pkgver}
31    make DESTDIR="${pkgdir}" install