archrelease: copy trunk to extra-x86_64
[arch-packages.git] / eog-plugins / trunk / PKGBUILD
blob049e402735620e05b1d8a6d8ac19be19dce16fe4
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=eog-plugins
4 pkgver=44.0
5 pkgrel=1
6 pkgdesc="Plugins for Eye of Gnome"
7 url="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
8 arch=(x86_64)
9 license=(GPL2)
10 depends=(
11   eog
12   libchamplain
13   libgdata
14   python-gobject
16 makedepends=(
17   git
18   gobject-introspection
19   meson
21 _commit=41f9d7d597cbd7423b186ab443b34a3e0feb9e94  # tags/44.0^0
22 source=("git+https://gitlab.gnome.org/GNOME/eog-plugins.git#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd $pkgname
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd $pkgname
34 build() {
35   arch-meson $pkgname build
36   meson compile -C build
39 check() {
40   meson test -C build --print-errorlogs
43 package() {
44   meson install -C build --destdir "$pkgdir"
47 # vim:set sw=2 sts=-1 et: