archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gettext / trunk / PKGBUILD
blobe375d900cdcb708fc8a9a6cb84e4a9621721b667
1 # Maintainer:
3 pkgname=gettext
4 pkgver=0.21.1
5 pkgrel=5
6 pkgdesc="GNU internationalization library"
7 url="https://www.gnu.org/software/gettext/"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gcc-libs acl sh libunistring libxml2)
11 makedepends=(gettext emacs git)
12 optdepends=('git: for autopoint infrastructure updates')
13 options=(!docs)
14 source=(https://ftp.gnu.org/pub/gnu/gettext/$pkgname-$pkgver.tar.gz{,.sig}
15         gettext-0.21-disable-libtextstyle.patch)
16 sha256sums=('e8c3650e1d8cee875c4f355642382c1df83058bd5a11ee8555c0cf276d646d45'
17             'SKIP'
18             '544ce0589e9c70f4f75d77c76fd36f88d009ac9cfecb4812a67f878e38ac6418')
19 validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871'  # Daiki Ueno
20               '68D94D8AAEEAD48AE7DC5B904F494A942E4616C2'
21               '9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development)
24 prepare() {
25   cd $pkgname-$pkgver
27   # Do not build libtextstyle, as it depends on libcroco
28   # which is now unmaintained and has known security bugs.
29   # patch from Fedora   
30   patch -p1 -i $srcdir/gettext-0.21-disable-libtextstyle.patch
33 build() {
34   cd $pkgname-$pkgver
36   autoreconf --force
38   ./configure \
39     --prefix=/usr \
40     --enable-csharp \
41     --enable-nls \
42     --with-xz \
43     --without-included-gettext
45   sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
46       -i gettext-{tools,runtime,runtime/libasprintf}/libtool
48   make
51 check() {
52   cd $pkgname-$pkgver
53   make check
56 package() {
57   cd $pkgname-$pkgver
58   make DESTDIR="$pkgdir" install