archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kguiaddons / trunk / PKGBUILD
blobd7f31875315329bdfff513400561a5b5ee2f59cf
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kguiaddons
6 pkgver=5.106.0
7 pkgrel=1
8 pkgdesc='Addons to QtGui'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(qt5-x11extras qt5-wayland)
13 makedepends=(extra-cmake-modules clang doxygen qt5-tools qt5-doc plasma-wayland-protocols)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('292357236c86066ef5e2680bc49537c9565d7f10c66666670e357d57e994b8d5'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF \
23     -DBUILD_QCH=ON
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build