archrelease: copy trunk to extra-x86_64
[arch-packages.git] / linux-manpages / repos / extra-any / PKGBUILD
blob6a9326df019072bfb759fcecf714668398f08adf
1 # $Id$
2 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
3 # Maintainer: Thomas Baechler <thomas@archlinux.org>
5 pkgname=linux-manpages
6 pkgver=4.10
7 pkgrel=1
8 pkgdesc="Kernel hackers manual - Section 9 manpages that comes with the Linux kernel."
9 arch=('any')
10 url="http://www.kernel.org"
11 license=('GPL2')
12 makedepends=('xmlto' 'docbook-xsl')
13 replaces=('kernel26-manpages')
14 conflicts=('kernel26-manpages')
15 provides=('kernel26-manpages')
16 options=('!zipman')
17 # https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
18 source=("https://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz")
19 sha256sums=('3c95d9f049bd085e5c346d2c77f063b8425f191460fcd3ae9fe7e94e0477dc4b')
21 build() {
22   cd "${srcdir}/linux-$pkgver"
23   make mandocs
26 package() {
27   cd "${srcdir}/linux-$pkgver"
28   # fix install path
29   sed -i -e "s:/usr/local/man/man9/:${pkgdir}/usr/share/man/man9/:g" Documentation/DocBook/Makefile
30   make installmandocs
32   #install -d "${pkgdir}/usr/share/man/man9/"
33   #install "${srcdir}"/linux-$pkgver/Documentation/DocBook/man/*/*.9.gz "${pkgdir}/usr/share/man/man9/"
35 #  find "${pkgdir}" -type f -exec chmod 644 {} \;