archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-www-robotrules / trunk / PKGBUILD
blobfecfc1214e0335861ffe7f1863d519ca74e23cca
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=perl-www-robotrules
4 pkgver=6.02
5 pkgrel=11
6 pkgdesc="Database of robots.txt-derived permissions"
7 arch=('any')
8 url="https://metacpan.org/release/WWW-RobotRules"
9 license=('PerlArtistic' 'GPL')
10 depends=('perl' 'perl-uri')
11 options=('!emptydirs')
12 source=(https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/WWW-RobotRules-${pkgver}.tar.gz)
13 sha256sums=('46b502e7a288d559429891eeb5d979461dd3ecc6a5c491ead85d165b6e03a51e')
15 build() {
16   cd "${srcdir}/WWW-RobotRules-${pkgver}"
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd "${srcdir}/WWW-RobotRules-${pkgver}"
23   make test
26 package() {
27   cd "${srcdir}/WWW-RobotRules-${pkgver}"
28   make DESTDIR="${pkgdir}" install