archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-asgiref / trunk / PKGBUILD
blob2b89e7174c29cf96f7b845d1a915191ecf66f4a9
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-asgiref
4 pkgver=3.6.0
5 pkgrel=1
6 pkgdesc="Reference ASGI adapters and channel layers"
7 arch=(any)
8 url="http://github.com/django/asgiref"
9 license=('BSD')
10 makedepends=('python-setuptools')
11 checkdepends=(python-pytest python-pytest-asyncio)
12 depends=('python')
13 source=("https://pypi.io/packages/source/a/asgiref/asgiref-${pkgver}.tar.gz")
14 sha256sums=('9567dfe7bd8d3c8c892227827c41cce860b368104c3431da67a0c5a65a949506')
16 build() {
17     cd "asgiref-${pkgver}"
18     python setup.py build
21 check() {
22     cd "asgiref-${pkgver}"
23     PYTHONPATH=. pytest .
26 package() {
27     cd "asgiref-${pkgver}"
28     python setup.py install --root=${pkgdir} --optimize=1
30     install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE