1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
4 pkgname=('zsh' 'zsh-doc')
8 url='https://www.zsh.org/'
10 makedepends=('pcre' 'libcap' 'gdbm' 'yodl')
11 source=("https://www.zsh.org/pub/zsh-${pkgver}"{,-doc}".tar.xz"{,.asc}
12 '0001-50629-do-not-use-egrep-in-tests.patch'
14 sha512sums=('d9138b7f379ad942a5f46819d2dd52d31f3a1129f2a0d1b53d4c5cd43c318b60396da6d37c57c477b8e958fb750209aca0ae93f8c9dd42ac958de006a0ff067e'
16 '5cc6abcdcfb4f5ad7bc4a31364ca49dfd87ae03e0082d89cc2ba1f00570f6757266ee60894ad31b562408de91494c22f177b414b03cb78c31d92328686be9860'
18 'af6a905e83807efb614a585ac1876e0a9cc8b745911b43915b06aab46757a6df6dfc64a7a60b53cc7e62e528c04aa7460e660a1de6720476030dd746af76c6e3'
19 'b287e00d8de4dc4cfb1c52bb2aef1d4b191de3512baad4c91dc81e78ddc3e5bb07297f43924b022ac44ff401a348d8a9fa366e19ddc8ea1ea72df311f5ed0034')
20 validpgpkeys=('F7B2754C7DE2830914661F0EA71D9A9D4BDB27B3'
21 'E96646BE08C0AF0AA0F90788A5FEEE3AC7937444'
22 '7CA7ECAAF06216B90F894146ACF8146CAE8CBBC4')
25 cd "${srcdir}/${pkgbase}-${pkgver}"
27 # 50629: do not use egrep in tests
28 patch -Np1 < ../0001-50629-do-not-use-egrep-in-tests.patch
30 # Set correct keymap path
31 sed -i 's#/usr/share/keymaps#/usr/share/kbd/keymaps#g' Completion/Unix/Command/_loadkeys
34 sed -i 's#/usr/share/misc/usb.ids#/usr/share/hwdata/usb.ids#g' Completion/Linux/Command/_lsusb
36 # Remove unneeded and conflicting completion scripts
37 for _fpath in AIX BSD Cygwin Darwin Debian Mandriva openSUSE Redhat Solaris; do
38 rm -rf Completion/$_fpath
39 sed "s#\s*Completion/$_fpath/\*/\*##g" -i Src/Zle/complete.mdd
41 rm Completion/Linux/Command/_pkgtool
43 # force generation of documentation with correct paths
48 cd "${srcdir}/${pkgbase}-${pkgver}"
50 ./configure --prefix=/usr \
51 --docdir=/usr/share/doc/zsh \
52 --htmldir=/usr/share/doc/zsh/html \
53 --enable-etcdir=/etc/zsh \
54 --enable-zshenv=/etc/zsh/zshenv \
55 --enable-zlogin=/etc/zsh/zlogin \
56 --enable-zlogout=/etc/zsh/zlogout \
57 --enable-zprofile=/etc/zsh/zprofile \
58 --enable-zshrc=/etc/zsh/zshrc \
59 --enable-maildir-support \
60 --with-term-lib='ncursesw' \
62 --enable-function-subdirs \
63 --enable-fndir=/usr/share/zsh/functions \
64 --enable-scriptdir=/usr/share/zsh/scripts \
69 --enable-zsh-secure-free
74 cd "${srcdir}/${pkgbase}-${pkgver}"
75 HOME="${srcdir}" make check
79 pkgdesc='A very advanced and programmable command interpreter (shell) for UNIX'
80 depends=('pcre' 'libcap' 'gdbm')
81 backup=('etc/zsh/zprofile')
84 cd "${srcdir}/${pkgbase}-${pkgver}"
85 make DESTDIR="${pkgdir}/" install
86 install -D -m644 "${srcdir}/zprofile" "${pkgdir}/etc/zsh/zprofile"
87 install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
91 pkgdesc='Info, HTML and PDF format of the ZSH documentation'
93 cd "${srcdir}/${pkgbase}-${pkgver}"
94 make DESTDIR="${pkgdir}/" install.info install.html
95 install -D -m644 Doc/zsh.pdf "${pkgdir}/usr/share/doc/zsh/zsh.pdf"
96 install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"