sbcl 2.3.0 rebuild
[arch-packages.git] / kdesignerplugin / repos / extra-x86_64 / PKGBUILD
blobc8174f0b7df5dc6b304e341bd8d452ff83d80292
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=kdesignerplugin
5 pkgver=5.101.0
6 pkgrel=1
7 pkgdesc='Integration of Frameworks widgets in Qt Designer/Creator'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(LGPL)
11 depends=(kconfig kcoreaddons)
12 makedepends=(extra-cmake-modules qt5-tools kdoctools)
13 groups=(kf5-aids)
14 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/portingAids/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('7a67b5a56df3c7a9279392b8aae3ccd26c5bed83ab0bff4cbbca84501abed986'
16             'SKIP')
17 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
18 options=(debug)
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build