sbcl 2.3.0 rebuild
[arch-packages.git] / perl-alien-libxml2 / trunk / PKGBUILD
blobb54a8081bf644d92ec1d55bcd5c3759dc8a33605
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-alien-libxml2
4 pkgver=0.19
5 pkgrel=1
6 pkgdesc="Install the C libxml2 library on your system"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/Alien-Libxml2"
10 depends=('libxml2' 'perl-alien-build')
11 makedepends=('perl-alien-build-plugin-download-gitlab' 'perl-html-parser' 'perl-sort-versions'
12              'perl-test2-suite' 'perl-uri')
13 options=('!emptydirs')
14 source=("https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Alien-Libxml2-$pkgver.tar.gz")
15 sha512sums=('02e4fab4fa4beacec3a6c932d11a3a8ea6648c084d5cb12a332b0e0e2f06eed595783d7673285bdf5e804a5a09bae1beb94261d6cfb4677decc7f1cfee3a3a76')
17 build() {
18   cd Alien-Libxml2-$pkgver
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd Alien-Libxml2-$pkgver
25   make test
28 package() {
29   cd Alien-Libxml2-$pkgver
30   make DESTDIR="$pkgdir" install