sbcl 2.3.0 rebuild
[arch-packages.git] / python / trunk / PKGBUILD
blob2d2478b41c19aa7cdd003d3a116e69280239a97f
1 # Maintainer: Angel Velasquez <angvp@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
4 # Contributor: Allan McRae <allan@archlinux.org>
5 # Contributor: Jason Chu <jason@archlinux.org>
7 shopt -s extglob
9 pkgbase=python
10 pkgname=(python python-tests)
11 pkgver=3.10.9
12 pkgrel=1
13 _pybasever=${pkgver%.*}
14 pkgdesc="Next generation of the python high-level scripting language"
15 arch=('x86_64')
16 license=('custom')
17 url="https://www.python.org/"
18 options=('debug')
19 depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'zlib')
20 makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb' 'ttf-font')
21 source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc})
22 sha512sums=('d66ea8adeb6dc4951e612175f8838b3092967ff275b7a3470f2d86f470036aa2221e722c3144d90bcd230b88efd53dde204213f72f703e524e4b833e2ccc68e2'
23             'SKIP')
24 validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D'  # Ned Deily (Python release signing key) <nad@python.org>
25               'E3FF2839C048B25C084DEBE9B26995E310250568'  # Łukasz Langa (GPG langa.pl) <lukasz@langa.pl>
26               'A035C8C19219BA821ECEA86B64E628F8D684696D') # Pablo Galindo Salgado <pablogsal@gmail.com>
28 prepare() {
29   cd Python-${pkgver}
31   # FS#23997
32   sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
34   # Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
35   # rather than copies shipped in the tarball
36   rm -r Modules/expat
37   rm -r Modules/_ctypes/{darwin,libffi}*
38   rm -r Modules/_decimal/libmpdec
41 build() {
42   cd Python-${pkgver}
44   # PGO should be done with -O3
45   CFLAGS="${CFLAGS/-O2/-O3} -ffat-lto-objects"
47   # Disable bundled pip & setuptools
48   ./configure --prefix=/usr \
49               --enable-shared \
50               --with-computed-gotos \
51               --enable-optimizations \
52               --with-lto \
53               --enable-ipv6 \
54               --with-system-expat \
55               --with-dbmliborder=gdbm:ndbm \
56               --with-system-libmpdec \
57               --enable-loadable-sqlite-extensions \
58               --without-ensurepip \
59               --with-tzpath=/usr/share/zoneinfo
61   # Obtain next free server number for xvfb-run; this even works in a chroot environment.
62   export servernum=99
63   while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
65   LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
68 check() {
69   # test_socket: test.test_socket.RDSTest.testPeek hangs https://bugs.python.org/issue35247
70   # test_tk: tkinter.test.test_tkinter.test_colorchooser.DefaultRootTest hangs
71   # test_pyexpat: our `debug` implementation rewrites source location, which breaks the build-time
72   #               only test test.test_pyexpat.HandlerExceptionTest as it cannot find source file in
73   #               the to-be-installed debug package
75   cd Python-${pkgver}
77   # Obtain next free server number for xvfb-run; this even works in a chroot environment.
78   export servernum=99
79   while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
81   LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
82   LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" \
83     "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_socket -x test_tk -x test_pyexpat
86 package_python() {
87   optdepends=('python-setuptools'
88               'python-pip'
89               'sqlite'
90               'mpdecimal: for decimal'
91               'xz: for lzma'
92               'tk: for tkinter')
93   provides=('python3')
94   replaces=('python3')
96   cd Python-${pkgver}
98   # Hack to avoid building again
99   sed -i 's/^all:.*$/all: build_all/' Makefile
101   # PGO should be done with -O3
102   CFLAGS="${CFLAGS/-O2/-O3}"
104   make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" install
106   # Why are these not done by default...
107   ln -s python3               "${pkgdir}"/usr/bin/python
108   ln -s python3-config        "${pkgdir}"/usr/bin/python-config
109   ln -s idle3                 "${pkgdir}"/usr/bin/idle
110   ln -s pydoc3                "${pkgdir}"/usr/bin/pydoc
111   ln -s python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python.1
113   # some useful "stuff" FS#46146
114   install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
115   install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
116   install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
118   # License
119   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
121   # Split tests
122   cd "$pkgdir"/usr/lib/python*/
123   rm -r {ctypes/test,distutils/tests,idlelib/idle_test,lib2to3/tests,sqlite3/test,tkinter/test,unittest/test}
124   cd test
125   # FS#76193
126   rm -r !(support)
129 package_python-tests() {
130   pkgdesc="Regression tests packages for Python"
131   depends=('python')
133   cd Python-${pkgver}
135   make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" libinstall
136   cd "$pkgdir"/usr/lib/python*/
137   rm -r !(test|ctypes|distutils|idlelib|lib2to3|sqlite3|tkinter|unittest)
138   cd "$pkgdir"/usr/lib/python*/test
139   rm -r support
140   cd "$pkgdir"/usr/lib/python*/ctypes
141   rm -r !(test)
142   cd "$pkgdir"/usr/lib/python*/distutils
143   rm -r !(tests)
144   cd "$pkgdir"/usr/lib/python*/idlelib
145   rm -r !(idle_test)
146   cd "$pkgdir"/usr/lib/python*/lib2to3
147   rm -r !(tests)
148   cd "$pkgdir"/usr/lib/python*/sqlite3
149   rm -r !(test)
150   cd "$pkgdir"/usr/lib/python*/tkinter
151   rm -r !(test)
152   cd "$pkgdir"/usr/lib/python*/unittest
153   rm -r !(test)