sbcl 2.3.0 rebuild
[arch-packages.git] / yelp / repos / extra-x86_64 / PKGBUILD
blobdb03fd466c4bbc9fc245077697338bfac7194284
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=yelp
5 pkgver=42.2
6 pkgrel=1
7 pkgdesc="Get help with GNOME"
8 url="https://wiki.gnome.org/Apps/Yelp"
9 license=(GPL)
10 arch=(x86_64)
11 depends=(webkit2gtk-4.1 yelp-xsl libxslt xz bzip2 libhandy)
12 makedepends=(itstool autoconf-archive git appstream-glib)
13 provides=(libyelp.so)
14 groups=(gnome)
15 options=(debug)
16 _commit=9fd1a84e1eae23db21939ff76c7e96d5422d3b1a  # tags/42.2^0
17 source=("git+https://gitlab.gnome.org/GNOME/yelp.git#commit=$_commit"
18         no-gtk-doc.diff)
19 sha256sums=('SKIP'
20             '795b8b6ee7cbbf6ccdbeba70ac8335becaaa6a44abe82f90c1c95d8113e4bf28')
22 pkgver() {
23   cd yelp
24   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd yelp
30   # Remove vestiges of docs build to allow building without gtk-doc
31   git apply -3 ../no-gtk-doc.diff
33   NOCONFIGURE=1 ./autogen.sh
36 build() {
37   cd yelp
38   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
39     --disable-static --enable-compile-warnings=minimum
40   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
41   make
44 package() {
45   cd yelp
46   make DESTDIR="$pkgdir" install