113.0-1
[arch-packages.git] / libdatrie / repos / extra-x86_64 / PKGBUILD
blob553f595b1495cfbe15351cdfa2a637695fd64d68
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Chaiwat Suttipongsakul <cwt114@gmail.com>
4 pkgname=libdatrie
5 pkgver=0.2.13
6 pkgrel=2
7 pkgdesc="Implementation of double-array structure for representing trie, as proposed by Junichi Aoe."
8 url="https://linux.thai.net/projects/datrie"
9 license=('LGPL')
10 arch=('x86_64')
11 depends=('glibc')
12 provides=('libdatrie.so')
13 options=('!emptydirs' 'debug')
14 source=(https://linux.thai.net/pub/thailinux/software/libthai/${pkgname}-${pkgver}.tar.xz)
15 md5sums=('e26b5aa008b5f3588ab38d2dce9e9325')
16 sha256sums=('12231bb2be2581a7f0fb9904092d24b0ed2a271a16835071ed97bed65267f4be')
18 build() {
19   cd "${srcdir}/${pkgname}-${pkgver}"
20   ./configure --prefix=/usr --disable-static
21   make
24 package() {
25   cd "${srcdir}/${pkgname}-${pkgver}"
26   make DESTDIR="${pkgdir}" install -j1