113.0-1
[arch-packages.git] / libimobiledevice / trunk / PKGBUILD
blobe878ed8acf5ab08eb00195ae11efb9d2ccc241c4
1 # Contributor: Tom Gundersen <teg@jklm.no>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
5 pkgname=libimobiledevice
6 pkgver=1.3.0
7 pkgrel=8
8 pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
9 url="https://libimobiledevice.org/"
10 arch=(x86_64)
11 license=(GPL2 LGPL2.1)
12 depends=(
13   gnutls
14   libgcrypt
15   libplist
16   libtasn1
17   libusbmuxd
19 makedepends=(
20   autoconf-archive
21   cython
22   git
23   python
24   python-setuptools
26 provides=(libimobiledevice-1.0.so)
27 _commit=15f8652126664e3a4b980e5d1c039b9053ce8566
28 source=(
29   "git+https://github.com/libimobiledevice/libimobiledevice#commit=$_commit"
30   libplist-2.3.0.diff
32 b2sums=('SKIP'
33         '136390910a57e70c3ce458ab5c6def4e079b7eb4c2946447102078ca511f8d112caf9460c074ecbb6c8a4f526e0aa50015d2f92acf66dbbb666bd007e361ee5e')
35 pkgver() {
36   cd $pkgname
37   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
40 prepare() {
41   cd $pkgname
43   # Update ac_python_devel.m4 to newer ax_python_devel.m4
44   git cherry-pick -n eea4f1be91
46   # Compatibility with libplist 2.3.0
47   git apply -3 ../libplist-2.3.0.diff
49   NOCONFIGURE=1 ./autogen.sh
52 build() (
53   cd $pkgname
54   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
55     --disable-openssl
56   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
57   make
60 check() {
61   cd $pkgname
62   make check
65 package() {
66   cd $pkgname
67   make DESTDIR="$pkgdir" install
70 # vim:set sw=2 sts=-1 et: