113.0-1
[arch-packages.git] / template-glib / trunk / PKGBUILD
blob6ed02ec6d047292e2a71e393c75401604efac273
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=template-glib
4 pkgver=3.36.1
5 pkgrel=1
6 pkgdesc="A templating library for GLib"
7 url="https://gitlab.gnome.org/GNOME/template-glib"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(glib2 gobject-introspection-runtime)
11 makedepends=(git meson vala gobject-introspection gtk-doc)
12 provides=(libtemplate_glib-1.0.so)
13 _commit=f7c21273599381494bc8d9b0633b93e14586471a  # tags/3.36.1^0
14 source=("git+https://gitlab.gnome.org/GNOME/template-glib.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -D gtk_doc=true
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: