1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="A templating library for GLib"
7 url="https://gitlab.gnome.org/GNOME/template-glib"
10 depends=(glib2 gobject-introspection-runtime)
11 makedepends=(git meson vala gobject-introspection gtk-doc)
12 provides=(libtemplate_glib-1.0.so)
13 _commit=f7c21273599381494bc8d9b0633b93e14586471a # tags/3.36.1^0
14 source=("git+https://gitlab.gnome.org/GNOME/template-glib.git#commit=$_commit")
19 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 arch-meson $pkgname build -D gtk_doc=true
28 meson compile -C build
32 meson test -C build --print-errorlogs
36 meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: