db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / gnome-shell-extensions / repos / extra-any / PKGBUILD
blobbe5a930774c541616c17236e01680782b44be094
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-shell-extensions
4 pkgver=44.0
5 pkgrel=1
6 pkgdesc="Extensions for GNOME shell, including classic mode"
7 url="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
8 arch=(any)
9 license=(GPL)
10 depends=(gnome-shell)
11 makedepends=(
12   git
13   meson
14   sassc
16 optdepends=('gnome-menus: applications menu extension')
17 groups=(gnome)
18 _commit=58b4b3c8d6c48432c81c4070829b29db5950a9cb  # tags/44.0^0
19 source=(
20   "git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions.git#commit=$_commit"
21   "git+https://gitlab.gnome.org/GNOME/gnome-shell-sass.git"
23 sha256sums=('SKIP'
24             'SKIP')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd $pkgname
34   git submodule init
35   git submodule set-url data/gnome-shell-sass "$srcdir/gnome-shell-sass"
36   git -c protocol.file.allow=always submodule update
39 build() {
40   local meson_options=(
41     -D extension_set=all
42     -D classic_mode=true
43   )
45   arch-meson $pkgname build "${meson_options[@]}"
46   meson compile -C build
49 check() {
50   meson test -C build --print-errorlogs
53 package() {
54   meson install -C build --destdir "$pkgdir"
57 # vim:set sw=2 sts=-1 et: