1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-shell-extensions
6 pkgdesc="Extensions for GNOME shell, including classic mode"
7 url="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
16 optdepends=('gnome-menus: applications menu extension')
18 _commit=58b4b3c8d6c48432c81c4070829b29db5950a9cb # tags/44.0^0
20 "git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions.git#commit=$_commit"
21 "git+https://gitlab.gnome.org/GNOME/gnome-shell-sass.git"
28 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
35 git submodule set-url data/gnome-shell-sass "$srcdir/gnome-shell-sass"
36 git -c protocol.file.allow=always submodule update
45 arch-meson $pkgname build "${meson_options[@]}"
46 meson compile -C build
50 meson test -C build --print-errorlogs
54 meson install -C build --destdir "$pkgdir"
57 # vim:set sw=2 sts=-1 et: