db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / gnome-sound-recorder / trunk / PKGBUILD
blob8cb22681c4692a8f9727cecfb0802008c1213613
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-sound-recorder
5 pkgver=42.0
6 pkgrel=2
7 pkgdesc="A utility to make simple audio recording from your GNOME desktop"
8 url="https://wiki.gnome.org/Apps/SoundRecorder"
9 arch=(any)
10 license=(GPL)
11 depends=(
12   gjs
13   gst-plugins-bad-libs
14   gst-plugins-base
15   gst-plugins-good
16   gtk4
17   libadwaita
19 makedepends=(
20   git
21   gobject-introspection
22   meson
24 groups=(gnome-extra)
25 _commit=0fabec18319c0baf0c627131c023f7c191af65d9  # tags/42.0^0
26 source=("git+https://gitlab.gnome.org/GNOME/gnome-sound-recorder.git#commit=$_commit")
27 b2sums=('SKIP')
29 pkgver() {
30   cd $pkgname
31   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
34 prepare() {
35   cd $pkgname
38 build() {
39   arch-meson $pkgname build
40   meson compile -C build
43 check() {
44   meson test -C build --print-errorlogs
47 package() {
48   meson install -C build --destdir "$pkgdir"
51 # vim:set sw=2 sts=-1 et: