1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
7 pkgdesc="A library to handle UPnP IGD port mapping"
8 url="https://wiki.gnome.org/Projects/GUPnP"
18 _commit=e60764858374d776869605d39e5e4d1033e9ad4a # tags/1.6.0^0
19 source=("git+https://gitlab.gnome.org/GNOME/gupnp-igd.git#commit=$_commit")
24 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 arch-meson $pkgname build -D gtk_doc=true
33 meson compile -C build
37 # No multicast in our containers?
38 meson test -C build --print-errorlogs || :
42 depends+=(libg{lib,object,io}-2.0.so libg{ssdp,upnp}-1.6.so)
43 provides+=(libgupnp-igd-1.6.so)
45 meson install -C build --destdir "$pkgdir"
48 # vim:set sw=2 sts=-1 et: