1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(libsoup3 libsoup3-docs)
8 pkgdesc="HTTP client/server library for GNOME"
9 url="https://wiki.gnome.org/Projects/libsoup"
35 _commit=b78cb58ee9b47f8ffe18697ee3b096743a01e6a8 # tags/3.4.2^0
36 source=("git+https://gitlab.gnome.org/GNOME/libsoup.git#commit=$_commit")
41 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
52 arch-meson libsoup build "${meson_options[@]}"
53 meson compile -C build
57 # Python's output buffering messes with the tests reading stdout lines from
58 # http2-server.py through a pipe
59 PYTHONUNBUFFERED=1 meson test -C build --print-errorlogs
66 libg{lib,object,io}-2.0.so
69 optdepends=('samba: Windows Domain SSO')
70 provides+=(libsoup-3.0.so)
72 meson install -C build --destdir "$pkgdir"
74 mkdir -p doc/usr/share
75 mv {"$pkgdir",doc}/usr/share/doc
78 package_libsoup3-docs() {
79 pkgdesc+=" (documentation)"
85 # vim:set sw=2 sts=-1 et: