db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / libverto / trunk / PKGBUILD
blob08a92fdbb7454c4935d3025e57683ae41d9327f0
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Mantas Mikulėnas <grawity@gmail.com>
4 pkgname=libverto
5 pkgver=0.3.2
6 pkgrel=4
7 pkgdesc="Main event loop abstraction library"
8 arch=('x86_64')
9 url="https://github.com/latchset/libverto"
10 license=(MIT)
11 depends=('glibc' 'libevent')
12 provides=('libverto.so' 'libverto-libevent.so' 'libverto-module-base')
13 conflicts=("krb5<1.19.3-2" "libverto-libevent<0.3.2-4")
14 replaces=("libverto-libevent<0.3.2-4")
15 source=("https://github.com/latchset/libverto/releases/download/$pkgver/libverto-$pkgver.tar.gz")
16 sha256sums=('8d1756fd704f147549f606cd987050fb94b0b1ff621ea6aa4d6bf0b74450468a')
18 build() {
19   cd "$pkgname-$pkgver"
20   ./configure --prefix=/usr \
21     --disable-static \
22     --with-libevent \
23     --without-libev \
24     --without-glib
25   make
28 check() {
29   cd "$pkgname-$pkgver"
30   make check
33 package_libverto() {
34   cd "$pkgname-$pkgver"
35   make DESTDIR="$pkgdir" install
37   install -Dm0644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"