db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / nasm / trunk / PKGBUILD
bloba26e15cd116e17803d20d0e11d875666f8abdbfc
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
4 pkgname=nasm
5 pkgver=2.16.01
6 pkgrel=1
7 pkgdesc='80x86 assembler designed for portability and modularity'
8 url='https://www.nasm.us'
9 arch=('x86_64')
10 license=('BSD')
11 depends=('glibc')
12 makedepends=('perl-font-ttf' 'perl-sort-versions' 'fontconfig' 'adobe-source-sans-pro-fonts'
13              'ttf-liberation' 'ghostscript' 'xmlto' 'asciidoc' 'diffutils')
14 source=(https://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz)
15 sha512sums=('51fccb5639ce019d9c423c0f279750ffbd74c64cd41dd3b185d1aa1a1aaed79c5d3cd8d4bebbc13ee249a375ed27457ea2abde1a4dbb24d354598fffd1254833')
16 b2sums=('0f7e96648e3db6fa4a8e10a89885f61cab7d79af25adbcc9d4706b3af61206c3cae024b7f873d636f5c1b2cb34ce5e7fbecc16af9b59086e9a1f49fb37c59670')
18 build() {
19   cd ${pkgname}-${pkgver}
20   ./configure --prefix=/usr
21   make
24 check() {
25   cd ${pkgname}-${pkgver}
26   make -j1 -C test golden test diff
29 package() {
30   cd ${pkgname}-${pkgver}
31   make DESTDIR="${pkgdir}" install
32   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/nasm
35 # vim: ts=2 sw=2 et: