db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / xdg-desktop-portal-gtk / trunk / PKGBUILD
blob25deea71812e20a513e4d22907b6b8d3b07de783
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Patrick Griffis <tingping@tingping.se>
5 pkgname=xdg-desktop-portal-gtk
6 pkgver=1.14.1
7 pkgrel=1
8 pkgdesc="A backend implementation for xdg-desktop-portal using GTK"
9 url="https://github.com/flatpak/xdg-desktop-portal-gtk"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(gtk3 gsettings-desktop-schemas)
13 makedepends=(xdg-desktop-portal python git)
14 optdepends=("evince: Print preview")
15 provides=(xdg-desktop-portal-impl)
16 _commit=952005f6a7850a247d286f14838202f506b402b7  # tags/1.14.1^0
17 source=("git+https://github.com/flatpak/xdg-desktop-portal-gtk#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
27   NOCONFIGURE=1 ./autogen.sh
30 build() {
31   cd $pkgname
32   ./configure --prefix=/usr --libexecdir=/usr/lib
33   make 
36 check() {
37   cd $pkgname
38   make check
41 package() {
42   cd $pkgname
43   DESTDIR="$pkgdir" make install
46 # vim:set sw=2 sts=-1 et: