db-move: moved linux from [testing] to [core] (x86_64)
[arch-packages.git] / at-spi2-core / repos / extra-x86_64 / PKGBUILD
blob2e1d700c587ad9214d040237ab23b4e3e39d73bd
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgbase=at-spi2-core
5 pkgname=(
6   at-spi2-core
7   at-spi2-core-docs
9 pkgver=2.48.0
10 pkgrel=2
11 pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
12 url="https://gitlab.gnome.org/GNOME/at-spi2-core"
13 arch=(x86_64)
14 license=(GPL2)
15 depends=(
16   dbus
17   glib2
18   gsettings-desktop-schemas
19   libx11
20   libxml2
21   libxtst
22   systemd
24 makedepends=(
25   dbus-broker
26   gi-docgen
27   git
28   gobject-introspection
29   meson
30   python-sphinx
32 checkdepends=(
33   at-spi2-core
35 _commit=d963aff7f6977e50517fb2ffe8b31f1db142107d  # tags/AT_SPI2_CORE_2_48_0^0
36 source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git#commit=$_commit")
37 b2sums=('SKIP')
39 pkgver() {
40   cd at-spi2-core
41   git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
44 prepare() {
45   cd at-spi2-core
48 build() {
49   local meson_options=(
50     -D default_bus=dbus-broker
51     -D docs=true
52   )
54   arch-meson at-spi2-core build "${meson_options[@]}"
55   meson compile -C build
58 check() {
59   dbus-run-session meson test -C build --print-errorlogs
62 package_at-spi2-core() {
63   optdepends=('dbus-broker: Alternative bus implementation')
64   provides=(
65     "at-spi2-atk=$pkgver-$pkgrel"
66     "atk=$pkgver-$pkgrel"
67     libatk-1.0.so
68     libatk-bridge-2.0.so
69     libatspi.so
70   )
71   conflicts=(
72     'at-spi2-atk<=2.38.0-2'
73     'atk<=2.38.0-2'
74   )
75   replaces=(
76     'at-spi2-atk<=2.38.0-2'
77     'atk<=2.38.0-2'
78   )
80   meson install -C build --destdir "$pkgdir"
82   mkdir -p doc/usr/share
83   mv {"$pkgdir",doc}/usr/share/doc
86 package_at-spi2-core-docs() {
87   pkgdesc+=" (documentation)"
88   depends=()
90   mv doc/* "$pkgdir"
93 # vim:set sw=2 sts=-1 et: