1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-power-manager
7 pkgdesc="System power information and statistics"
8 url="https://gitlab.gnome.org/GNOME/gnome-power-manager"
11 depends=(gtk3 upower dconf)
12 makedepends=(git meson)
13 _commit=98f8ac8275d413f141a3f422e731e3213fc1db03 # tags/GNOME_POWER_MANAGER_43_0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-power-manager.git#commit=$_commit")
19 git describe --tags | sed 's/^GNOME_POWER_MANAGER_//;s/_/./g;s/-/+/g'
27 arch-meson $pkgname build
28 meson compile -C build
32 meson test -C build --print-errorlogs
36 meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: