db-move: moved linux from [testing] to [core] (x86_64)
[arch-packages.git] / gnome-power-manager / trunk / PKGBUILD
blob5260f19c4db02f94cb02142f03f908ed49f8aa9a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-power-manager
5 pkgver=43.0
6 pkgrel=1
7 pkgdesc="System power information and statistics"
8 url="https://gitlab.gnome.org/GNOME/gnome-power-manager"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 upower dconf)
12 makedepends=(git meson)
13 _commit=98f8ac8275d413f141a3f422e731e3213fc1db03  # tags/GNOME_POWER_MANAGER_43_0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-power-manager.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/^GNOME_POWER_MANAGER_//;s/_/./g;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: