db-move: moved linux from [testing] to [core] (x86_64)
[arch-packages.git] / klettres / trunk / PKGBUILD
blob66dae1fa460480c155608174aadba84cf45bb2b5
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=klettres
5 pkgver=23.04.0
6 pkgrel=1
7 pkgdesc='Learn The Alphabet'
8 url='https://apps.kde.org/klettres/'
9 arch=(x86_64)
10 license=(GPL LGPL FDL)
11 groups=(kde-applications kde-education)
12 depends=(knewstuff phonon-qt5 hicolor-icon-theme)
13 makedepends=(extra-cmake-modules kdoctools)
14 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('f2787e70720853593a557f70c24a8705bb35c8921585a037a27a576da1755128'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build